DOCUMENTATION

Intégration d'un widget sur Wordpress

Nous contacter

Alliance Réseaux
26 rue Saint Exupéry
73300 Saint-Jean-de-Maurienne
support@alliance-reseaux.com

Il faut bien distinguer deux versions :

 

  • la version “autonome” qui nécessite le téléchargement du logiciel Wordpress et son installation sur un hébergement web. Cette version est recommandée si vous avez des connaissances en développement et administration de site internet.

 

 

A noter que la version dite “en ligne” est plus restreinte que la version “autonome” et ne permet pas nativement d’implémenter des widgets Open System.

 

  1. version Wordpress “autonome”

 

Si vous utilisez cette version de Wordpress, alors libre à vous de faire ce que bon vous semble. Il n’y a en effet aucune restriction technique pour l’intégration de nos widgets de réservation Open System.

 

Nous rappelons juste les fondamentaux : mettre le widget produit le plus haut possible dans la page afin qu’il soit rapidement visible par l’internaute qui souhaite réserver. Aussi, pensez à mettre dans le header de votre site, le widget panier qui permettra à l’internaute de finaliser sa commande même si il consulte d’autres pages de votre site.

 

Nous vous avons fourni le script d’instanciation de nos widgets :

 

<script type="text/javascript" src="//gadget.open-system.fr/widgets-libs/rel/noyau-1.0.min.js"></script>

 

<script type="text/javascript">

     ( function() {

           var widgetProduit = AllianceReseaux.Widget.Instance( "Produit", { idPanier:"ZZZZZ", idIntegration:000, langue:"fr", ui:"XXXX-0000" } );

           widgetProduit.Initialise();

     })();

</script>

 

<div id="widget-produit-XXXX-0000"></div>

 

et pour le Widget Panier :

 

<script type="text/javascript" src="//gadget.open-system.fr/widgets-libs/rel/noyau-1.0.min.js"></script>

 

<script type="text/javascript" >
     ( function() {
           var widgetPanier = AllianceReseaux.Widget.Instance( "Panier", { idPanier:"ZZZZZ", idIntegration:000, langue:"fr" } );
           widgetPanier.Initialise();
     })();
</script>
<div id="widget-panier"></div>


 

  1. version Wordpress “en ligne”

 

A ce jour, il n’existe pas de solution pour intégrer nos widgets de réservations dans cette version de Wordpress. En effet, la plateforme impose des règles de sécurité qui fait que les appels de scripts externes, ne fonctionne pas.